summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/PalmSDK')
-rw-r--r--dev-embedded/PalmSDK/ChangeLog9
-rw-r--r--dev-embedded/PalmSDK/Manifest5
-rw-r--r--dev-embedded/PalmSDK/PalmSDK-1.4.1.427.ebuild101
-rw-r--r--dev-embedded/PalmSDK/files/PalmSDK-palm-emulator.pngbin0 -> 3658 bytes
-rw-r--r--dev-embedded/PalmSDK/metadata.xml6
5 files changed, 121 insertions, 0 deletions
diff --git a/dev-embedded/PalmSDK/ChangeLog b/dev-embedded/PalmSDK/ChangeLog
new file mode 100644
index 000000000..73b08d023
--- /dev/null
+++ b/dev-embedded/PalmSDK/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-embedded/PalmSDK
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 29 Apr 2010; Michael Weber (xmw) <gentoo@xmw.de>
+ +PalmSDK-1.4.1.427.ebuild, +files/PalmSDK-palm-emulator.png,
+ +metadata.xml:
+ New Ebuild for bug 278769
+
diff --git a/dev-embedded/PalmSDK/Manifest b/dev-embedded/PalmSDK/Manifest
new file mode 100644
index 000000000..6ae59ba6d
--- /dev/null
+++ b/dev-embedded/PalmSDK/Manifest
@@ -0,0 +1,5 @@
+AUX PalmSDK-palm-emulator.png 3658 RMD160 e42fcccd24640c99143d5e7e9c426589adcf3b1e SHA1 d5077d68f22da6c7f9a7c3d8ff5586e8f5b32732 SHA256 bfe2d8518ab65c73f2f6813d4b22e8488d0596d1ee548840924f2b35c5c65e14
+DIST palm-sdk_1.4.1-svn274946-sdk1436-pho427_i386.deb 198840002 RMD160 a72700809375cbaa359254761669b35128b7e324 SHA1 64f424d9661b679ee888fa253854d603885e5ed8 SHA256 00352167f8bd4260c3bf66ac91101cea054c34ec2cfc7b0c0b84857e8e464e35
+EBUILD PalmSDK-1.4.1.427.ebuild 3034 RMD160 c7e43b76498deefa260a1db8d71edc964237c4e4 SHA1 c37c345d359f48dac2e6873a7e50198f29c289e4 SHA256 cb9694d45ec875a9ccc8c1039378d07cfa868df3e944e114c577ca934eed3ef5
+MISC ChangeLog 281 RMD160 dd8bd4a82d40893d4c08bdcf0123d5cde36c2b2a SHA1 f58e6448cbc843ab6898559fb934a81017f0cc6d SHA256 a05b73fba74568d2ab9f4045d7f88dcfdc9de74d13434514c40ee2d775f55868
+MISC metadata.xml 229 RMD160 f0f6417bec31ce8baba6d476664f7210c8c84c98 SHA1 e5f94f5caadc6f843fc90bb7959570cd503676fd SHA256 3b08fca3c878bdfc4e7639f477dd542d55a4ab5dce39a475e82633071d13eb3f
diff --git a/dev-embedded/PalmSDK/PalmSDK-1.4.1.427.ebuild b/dev-embedded/PalmSDK/PalmSDK-1.4.1.427.ebuild
new file mode 100644
index 000000000..3d110074d
--- /dev/null
+++ b/dev-embedded/PalmSDK/PalmSDK-1.4.1.427.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils versionator
+
+DESCRIPTION="Palm WebOS SDK with Mojo Application Framework and emulator to develop Palm Pre applications"
+HOMEPAGE="http://developer.palm.com/"
+
+MY_VER="$(get_version_component_range 1-3)-svn274946-sdk1436-pho$(get_version_component_range 4)"
+SRC_URI="http://cdn.downloads.palm.com/sdkdownloads/${PV}/sdkBinaries/palm-sdk_${MY_VER}_i386.deb"
+
+LICENSE="${PN}"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 -*"
+MY_LINGUAS="linguas_de linguas_it linguas_pt_BR linguas_ru linguas_sv"
+IUSE=${MY_LINGUAS}
+
+RDEPEND="|| (
+ app-emulation/virtualbox-bin
+ app-emulation/virtualbox-ose
+ )
+ >=virtual/jre-1.5
+ x86? (
+ net-libs/libproxy
+ net-libs/libsoup:2.4
+ net-libs/libsoup-gnome:2.4
+ net-libs/webkit-gtk
+ x11-libs/gtk+:2
+ )"
+
+QA_PRESTRIPPED_x86="
+ opt/PalmSDK/0.1/bin/palminspector
+ opt/PalmSDK/0.1/bin/proxy"
+QA_PRESTRIPPED_amd64="${QA_PRESTRIPPED_x86}
+ opt/PalmSDK/0.1/lib/libproxy.so
+ opt/PalmSDK/0.1/lib/libproxy.so.0
+ opt/PalmSDK/0.1/lib/libproxy.so.0.0.0
+ opt/PalmSDK/0.1/lib/libproxy/0.2.3/plugins/envvar.so
+ opt/PalmSDK/0.1/lib/libproxy/0.2.3/plugins/file.so
+ opt/PalmSDK/0.1/lib/libproxy/0.2.3/plugins/gnome.so
+ opt/PalmSDK/0.1/lib/libproxy/0.2.3/plugins/kde.so"
+
+src_unpack() {
+ unpack ${A}
+ unpack ./data.tar.gz
+}
+
+src_prepare() {
+ local my_linguas
+ for my_linguas in ${MY_LINGUAS} ; do
+ use ${my_linguas} && continue
+ rm -rf "opt/${PN}/0.1/share/locale/${my_linguas#linguas_}" || die
+ done
+
+ rm -rf opt/${PN}/0.1/lib/lib{soup,webkit}* || die
+
+ if use x86 ; then
+ rm -rf opt/${PN}/0.1/lib/libproxy* || die
+ fi
+}
+
+src_install() {
+ local my_bin
+ for my_bin in $(find opt/${PN}/0.1/bin -maxdepth 1 -type f) ; do
+ dosym "/${my_bin}" "/opt/bin/$(basename "${my_bin}")" || die
+ done
+
+ insinto opt/${PN}
+ doins -r opt/${PN}/0.1 || die
+ fperms -R a+x /opt/${PN}/0.1/{bin,lib} || die
+
+ dosym 0.1 opt/PalmSDK/Current || die
+
+ newicon "${FILESDIR}/${PN}-palm-emulator.png" palm-emulator.png || die
+ make_desktop_entry /opt/bin/palm-emulator "Palm Mojo SDK Emulator" palm-emulator Development
+
+ if use amd64 ; then
+ ewarn "palminspector does not work on amd64 due to missing 32bit libraries "
+ ewarn "libenchant.so.1 libicu{data,i18n,uc}.so.38 and libgnutls.so.13."
+ ewarn "The execute bit will be removed to silence revdep-rebuild."
+ ewarn "You can obtain these by using portage2.2 and multilib overlay."
+ ewarn "See http://github.com/sjnewbury/multilib-overlay for details."
+ fperms a-x /opt/${PN}/0.1/bin/palminspector || die
+ fi
+}
+
+pkg_postinst() {
+ if ! grep 'localhost' /etc/hosts | grep -s -q '127.0.0.1' ; then
+ ewarn 'Add "127.0.0.1 localhost" to your /etc/hosts'
+ fi
+ if ! grep -s -q '127.0.0.1 qemu' /etc/hosts ; then
+ ewarn 'Add "127.0.0.1 qemu" to your /etc/hosts'
+ fi
+ if ! grep -s -q '192.168.2.101 device' /etc/hosts ; then
+ ewarn 'Add something like "192.168.2.101 device" to your /etc/hosts'
+ fi
+ elog 'Do not forget to add your account to the vboxusers group!'
+}
diff --git a/dev-embedded/PalmSDK/files/PalmSDK-palm-emulator.png b/dev-embedded/PalmSDK/files/PalmSDK-palm-emulator.png
new file mode 100644
index 000000000..cd0c05d1d
--- /dev/null
+++ b/dev-embedded/PalmSDK/files/PalmSDK-palm-emulator.png
Binary files differ
diff --git a/dev-embedded/PalmSDK/metadata.xml b/dev-embedded/PalmSDK/metadata.xml
new file mode 100644
index 000000000..e6233b5dc
--- /dev/null
+++ b/dev-embedded/PalmSDK/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer><email>maintainer-wanted@gentoo.org</email></maintainer>
+</pkgmetadata>