summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libcitadel/libcitadel-7.84.ebuild')
-rw-r--r--dev-libs/libcitadel/libcitadel-7.84.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/libcitadel/libcitadel-7.84.ebuild b/dev-libs/libcitadel/libcitadel-7.84.ebuild
new file mode 100644
index 000000000..b18edf0ab
--- /dev/null
+++ b/dev-libs/libcitadel/libcitadel-7.84.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit flag-o-matic
+
+DESCRIPTION="Contains code which is shared across all the components which make up the Citadel system"
+HOMEPAGE="http://citadel.org/"
+SRC_URI="http://easyinstall.citadel.org/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/db
+ >=dev-libs/libical-0.43
+ mail-filter/libsieve
+ dev-libs/expat
+ net-misc/curl"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ filter-flags -finline-functions
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}