summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/librets/files/librets-1.6.1-fix-php-build-errors.patch')
-rw-r--r--dev-libs/librets/files/librets-1.6.1-fix-php-build-errors.patch77
1 files changed, 0 insertions, 77 deletions
diff --git a/dev-libs/librets/files/librets-1.6.1-fix-php-build-errors.patch b/dev-libs/librets/files/librets-1.6.1-fix-php-build-errors.patch
deleted file mode 100644
index 0d63bc962..000000000
--- a/dev-libs/librets/files/librets-1.6.1-fix-php-build-errors.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-commit 59e5e7af0e2c19ae2461e3eb071c2344629b8543
-Author: Keith T. Garner <kgarner@realtors.org>
-Date: Wed Apr 9 11:20:17 2014 -0500
-
- Rewrote the php configure test to use php-config.
-
-diff --git a/project/build/ac-macros/swig.m4 b/project/build/ac-macros/swig.m4
-index 4280d55..c267dc2 100644
---- a/project/build/ac-macros/swig.m4
-+++ b/project/build/ac-macros/swig.m4
-@@ -168,25 +168,21 @@ EOF
- dnl Check to see if we can build for php
- dnl
- if test "$my_use_php" = "yes"; then
-- AC_CHECK_PROG(PHP, php, php, no)
-- if test "$PHP" != "no"; then
-- for php_prefix in $default_search_path
-- do
-- php_h="$php_prefix/php/main/php.h"
-- zend_h="$php_prefix/php/Zend/zend.h"
-- AC_CHECK_FILE([$php_h], [my_php_h=$php_h])
-- AC_CHECK_FILE([$zend_h], [my_zend_h=$zend_h])
-- test -n "$my_php_h" && break
-- test -n "$my_zend_h" && break
-- done
-+ AC_CHECK_PROG(PHPCONFIG, php-config, php-config, no)
-+ if test "$PHPCONFIG" != "no"; then
-+ php_inc=`php-config --include-dir`
-+ php_h="$php_inc/main/php.h"
-+ zend_h="$php_inc/Zend/zend.h"
-+ AC_CHECK_FILE([$php_h], [my_php_h=$php_h])
-+ AC_CHECK_FILE([$zend_h], [my_zend_h=$zend_h])
- if test -n "$my_php_h"; then
- if test -n "$my_zend_h"; then
- HAVE_PHP=1
- my_have_php=yes
- fi
-- fi
-+ fi
- fi
-- fi
-+ fi
-
- dnl
- dnl Check to see if we can build for python3
-
-commit fc3df0736cbea41b661979f91a400f12b397d02a
-Author: Keith T. Garner <kgarner@realtors.org>
-Date: Wed Apr 9 18:04:38 2014 -0500
-
- Allow php to link with undefines as its a plugin and that's expected
-
-diff --git a/project/build/php.mk b/project/build/php.mk
-index e031492..5b318cd 100644
---- a/project/build/php.mk
-+++ b/project/build/php.mk
-@@ -18,7 +18,7 @@ ${PHP_WRAP}: ${SWIG_FILES}
- -outdir ${PHP_OBJ_DIR} ${SWIG_DIR}/librets.i
-
- ${PHP_DLL}: ${PHP_WRAP} ${PHP_OBJ_DIR}/librets_wrap.o ${SWIG_BRIDGE_OBJ} ${LIBRETS_LIB}
-- ${SWIG_LINK} -o ${PHP_DLL} ${PHP_OBJ_DIR}/librets_wrap.o ${SWIG_LIBRETS_LIBS} ${SWIG_BRIDGE_OBJ}
-+ ${SWIG_LINK_UNDEFINED} -o ${PHP_DLL} ${PHP_OBJ_DIR}/librets_wrap.o ${SWIG_LIBRETS_LIBS} ${SWIG_BRIDGE_OBJ}
-
- ${PHP_OBJ_DIR}/librets_wrap.o: ${PHP_OBJ_DIR}/librets_wrap.cpp
- ${CXX} ${CXXFLAGS} ${PHP_CXX_FLAGS} -g -DLIBRETS_VERSION='"$(VERSION)"' -I${LIBRETS_INC_DIR} -I${PHP_SRC_DIR} \
-diff --git a/project/build/swig.mk b/project/build/swig.mk
-index 4dfa1fa..c853f3e 100644
---- a/project/build/swig.mk
-+++ b/project/build/swig.mk
-@@ -20,6 +20,7 @@ SWIG_BRIDGE_OBJ = ${SWIG_OBJ_DIR}/librets_bridge.o
-
- DLL = so
- SWIG_LINK = ${CXX} ${LDFLAGS} -shared -Wl,--no-undefined
-+SWIG_LINK_UNDEFINED = ${CXX} ${LDFLAGS} -shared
-
- ifeq (${SWIG_OSNAME}, darwin)
- SWIG_LINK = ${CXX} -bundle -undefined suppress -flat_namespace