summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/uthash/uthash-1.5.ebuild')
-rw-r--r--dev-libs/uthash/uthash-1.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/uthash/uthash-1.5.ebuild b/dev-libs/uthash/uthash-1.5.ebuild
new file mode 100644
index 000000000..69b296ee2
--- /dev/null
+++ b/dev-libs/uthash/uthash-1.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit toolchain-funcs
+
+DESCRIPTION="An easy-to-use hash implementation for C programmers"
+HOMEPAGE="http://uthash.sourceforge.net"
+SRC_URI="mirror://sourceforge/uthash/${P}.tar.bz2"
+
+LICENSE="BSD-1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc"
+IUSE="test"
+
+DEPEND="test? ( dev-lang/perl )"
+RDEPEND=""
+
+src_test() {
+ cd tests
+ sed -i "/CFLAGS/s/-O3/${CFLAGS}/" Makefile || die "sed cflags failed"
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ insinto /usr/include
+ doins src/uthash.h || die "doins failed"
+
+ dodoc doc/txt/{ChangeLog,userguide}.txt || die "dodoc failed"
+}