summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/xml-security-c/xml-security-c-1.4.0.ebuild')
-rw-r--r--dev-libs/xml-security-c/xml-security-c-1.4.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/xml-security-c/xml-security-c-1.4.0.ebuild b/dev-libs/xml-security-c/xml-security-c-1.4.0.ebuild
new file mode 100644
index 000000000..70800fd12
--- /dev/null
+++ b/dev-libs/xml-security-c/xml-security-c-1.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Apache C++ XML security libraries."
+HOMEPAGE="http://santuario.apache.org/"
+SRC_URI="http://xml.apache.org/security/dist/c-library/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="xalan"
+
+RDEPEND="dev-libs/xerces-c
+ xalan? ( dev-libs/xalan-c )
+ dev-libs/openssl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile () {
+ econf $(use_with xalan)
+ emake || die "emake failed"
+}
+
+src_install(){
+ emake DESTDIR="${D}" install || die "emake failed"
+}