summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/awl/libawl-php-0.31.ebuild')
-rw-r--r--dev-php/awl/libawl-php-0.31.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-php/awl/libawl-php-0.31.ebuild b/dev-php/awl/libawl-php-0.31.ebuild
new file mode 100644
index 000000000..02827f808
--- /dev/null
+++ b/dev-php/awl/libawl-php-0.31.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils git php-lib-r1
+
+DESCRIPTION="Andrew McMillan's web libraries: A collection of generic classes
+used by the davical calendar server"
+HOMEPAGE="http://andrew.mcmillan.net.nz/projects/awl"
+EGIT_REPO_URI="http://repo.or.cz/r/awl.git"
+EGIT_TREE="${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( dev-php/PEAR-PhpDocumentor )"
+RDEPEND="${DEPEND}"
+
+need_php5
+
+pkg_setup() {
+ require_php_with_use pcre postgres xml
+}
+
+src_compile() {
+ if use doc ; then
+ ebegin "Generating documentation"
+ phpdoc -c "docs/api/phpdoc.ini"
+ eend $? || die "Documentation failed to build"
+ fi
+}
+
+src_install() {
+ local docs="debian/README.Debian debian/changelog"
+ dodoc-php ${docs} || die "dodoc failed"
+
+ if use doc ; then
+ dohtml -r "docs/api/" || die "dohtml failed"
+ fi
+
+ insinto /usr/share/awl
+ doins -r dba || die "doins failed"
+
+ php-lib-r1_src_install ./inc `find ./inc -type f -print | sed -e "s|./inc||g"`
+}