summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/amara/amara-1.2.0.1.ebuild')
-rw-r--r--dev-python/amara/amara-1.2.0.1.ebuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/dev-python/amara/amara-1.2.0.1.ebuild b/dev-python/amara/amara-1.2.0.1.ebuild
index f99bd651d..a8ae110ea 100644
--- a/dev-python/amara/amara-1.2.0.1.ebuild
+++ b/dev-python/amara/amara-1.2.0.1.ebuild
@@ -2,10 +2,13 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+NEED_PYTHON=2.4
+
inherit distutils multilib
MY_PN=Amara
MY_P=${MY_PN}-${PV}
+
DESCRIPTION="Python tools for XML processing."
HOMEPAGE="http://uche.ogbuji.net/uche.ogbuji.net/tech/4suite/amara/"
SRC_URI="http://cheeseshop.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.bz2"
@@ -18,26 +21,27 @@ IUSE="doc examples"
RDEPEND=">=dev-python/4suite-1.0.2
dev-python/python-dateutil"
DEPEND="${RDEPEND}
- doc? ( dev-python/epydoc )"
+ dev-python/setuptools
+ doc? ( dev-python/epydoc )"
S=${WORKDIR}/${MY_P}
-DOCS="ACKNOWLEDGEMENTS CHANGES README TODO docs/quickref.txt"
+src_compile() {
+ distutils_src_compile
+ if use doc ; then
+ einfo "Generating docs as requested..."
+ PYTHONPATH=./build/lib/ epydoc amara || die "generating docs failed"
+ fi
+}
src_install() {
+ DOCS="ACKNOWLEDGEMENTS CHANGES docs/quickref.txt"
distutils_src_install
- dohtml manual.html
-
if use examples; then
insinto /usr/share/doc/${PF}/examples
doins -r demo/*
fi
- if use doc; then
- distutils_python_version
- export PYTHONPATH="${PYTHONPATH}:${D}/usr/$(get_libdir)/python${PYVER}/site-packages"
- epydoc amara
- dohtml -r html/*
- fi
+ use doc && dohtml -r html/*
}