summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cx-oracle/cx-oracle-5.0.2.ebuild')
-rw-r--r--dev-python/cx-oracle/cx-oracle-5.0.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/cx-oracle/cx-oracle-5.0.2.ebuild b/dev-python/cx-oracle/cx-oracle-5.0.2.ebuild
new file mode 100644
index 000000000..38ae833f8
--- /dev/null
+++ b/dev-python/cx-oracle/cx-oracle-5.0.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit distutils
+
+MY_PN=cx_Oracle
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Python interface to Oracle"
+HOMEPAGE="http://www.cxtools.net/default.aspx?nav=cxorlb"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="Computronix"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND=">=dev-db/oracle-instantclient-basic-10.2.0.3"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="README.txt HISTORY.txt"
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r html/* || die
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc samples/* || die
+ fi
+}