summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-debugtoolbar/flask-debugtoolbar-0.6.2.ebuild')
-rw-r--r--dev-python/flask-debugtoolbar/flask-debugtoolbar-0.6.2.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/flask-debugtoolbar/flask-debugtoolbar-0.6.2.ebuild b/dev-python/flask-debugtoolbar/flask-debugtoolbar-0.6.2.ebuild
deleted file mode 100644
index c9b07c6c3..000000000
--- a/dev-python/flask-debugtoolbar/flask-debugtoolbar-0.6.2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
-
-inherit distutils
-
-MY_PN="Flask-DebugToolbar"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A port of the Django debug toolbar to Flask"
-HOMEPAGE="http://flask-debugtoolbar.rtfd.org/ https://github.com/mgood/flask-debugtoolbar"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples"
-
-RDEPEND=">=dev-python/flask-0.8
- dev-python/blinker
- doc? ( dev-python/sphinx )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="flask_debugtoolbar"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- pushd docs > /dev/null
- emake html || die "Generation of documentation failed"
- popd > /dev/null
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r example || die "Installation of examples failed"
- fi
-
- if use doc; then
- dohtml -A txt -r docs/_build/html/* || die "dohtml failed"
- fi
-}