summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/iniparse/iniparse-0.4.ebuild')
-rw-r--r--dev-python/iniparse/iniparse-0.4.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/dev-python/iniparse/iniparse-0.4.ebuild b/dev-python/iniparse/iniparse-0.4.ebuild
index 1596d3f65..4a661b456 100644
--- a/dev-python/iniparse/iniparse-0.4.ebuild
+++ b/dev-python/iniparse/iniparse-0.4.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
-PYTHON_DEPEND="2:2.6"
-RESTRICT_PYTHON_ABIS="2.[45] 3.*"
+PYTHON_DEPEND="2"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
@@ -18,3 +18,10 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" runtests.py
+ }
+ python_execute_function testing
+}