summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/shm/shm-1.1.1.ebuild')
-rw-r--r--dev-python/shm/shm-1.1.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/shm/shm-1.1.1.ebuild b/dev-python/shm/shm-1.1.1.ebuild
new file mode 100644
index 000000000..210a930ed
--- /dev/null
+++ b/dev-python/shm/shm-1.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+DESCRIPTION="An implementation of shared memory access for Python."
+HOMEPAGE="http://nikitathespider.com/python/shm/"
+SRC_URI="http://nikitathespider.com/python/shm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+# $S is set to $WORKDIR/$P by default
+# this is not correct here
+S="${WORKDIR}"
+
+src_install()
+{
+ python_version
+ distutils_src_install
+
+ insinto "/usr/$(get_libdir)/python${PYVER}/site-packages"
+ doins "${S}/shm_wrapper.py"
+}