summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/spawning/spawning-0.9.1.ebuild')
-rw-r--r--dev-python/spawning/spawning-0.9.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/spawning/spawning-0.9.1.ebuild b/dev-python/spawning/spawning-0.9.1.ebuild
new file mode 100644
index 000000000..cf53b640c
--- /dev/null
+++ b/dev-python/spawning/spawning-0.9.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+MY_PN=Spawning
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="A flexible web server written in Python"
+HOMEPAGE="http://pypi.python.org/pypi/Spawning"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND="dev-lang/python
+ >=dev-python/eventlet-0.9
+ dev-python/pastedeploy
+ dev-python/simplejson"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ distutils_src_install
+
+ doinitd rc-scripts/init.d/spawn || die "Install failed"
+ doconfd rc-scripts/conf.d/spawn || die "Install failed"
+}