summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/bugle/ChangeLog4
-rw-r--r--dev-util/bugle/bugle-0.0.20061109.ebuild54
-rw-r--r--dev-util/bugle/files/bugle-0.0.20061109-makefile-typo.patch11
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-util/bugle/ChangeLog b/dev-util/bugle/ChangeLog
index 0cb927ff4..4f7989eda 100644
--- a/dev-util/bugle/ChangeLog
+++ b/dev-util/bugle/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 09 Nov 2006; Wolfgang Frisch (xororand) <xororand@frexx.de>
+ +bugle-0.0.20061109.ebuild, +files/bugle-0.0.20061109-makefile-typo.patch:
+ Version bump, corrected gtk+ dependency + new patch
+
02 Nov 2006; Wolfgang Frisch (xororand) <xororand@frexx.de>
+bugle-0.0.20061022.ebuild, +files/ccache-dtu-bug.patch, +metadata.xml:
New Ebuild for bug 143835 (BuGLe)
diff --git a/dev-util/bugle/bugle-0.0.20061109.ebuild b/dev-util/bugle/bugle-0.0.20061109.ebuild
new file mode 100644
index 000000000..20422eed0
--- /dev/null
+++ b/dev-util/bugle/bugle-0.0.20061109.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+# Wolfgang Frisch <xororand@frexx.de>
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A tool for OpenGL debugging"
+HOMEPAGE="http://bugle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bugle/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ffmpeg gtk readline"
+
+DEPEND="
+ ffmpeg? ( media-video/ffmpeg )
+ gtk? ( >=x11-libs/gtk+-2.4.0 >=x11-libs/gtkglext-1.0.0 )
+ readline? ( sys-libs/readline )
+ sys-libs/ncurses"
+
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/bugle-0.0.20061109-makefile-typo.patch"
+}
+
+src_compile() {
+ if [ "$(gcc-version)" == "4.0" ]; then
+ die "BuGLe doesn't work with gcc-4.0. Use gcc-3.x or >=gcc-4.1."
+ fi
+
+ econf \
+ $(use_with ffmpeg) \
+ $(use_with readline) \
+ $(use_with gtk) \
+ $(use_with gtk gtkglext) \
+ || die "econf failed"
+ emake DESTDIR="${D}" || die "emake failed"
+}
+
+src_install() {
+ dodoc README TODO TROUBLESHOOTING LICENSE FAQ doc/*.{txt,html}
+ docinto examples
+ dodoc doc/examples/*
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ einfo "See man 3 bugle for an introduction to BuGLe."
+}
diff --git a/dev-util/bugle/files/bugle-0.0.20061109-makefile-typo.patch b/dev-util/bugle/files/bugle-0.0.20061109-makefile-typo.patch
new file mode 100644
index 000000000..a08afb0fc
--- /dev/null
+++ b/dev-util/bugle/files/bugle-0.0.20061109-makefile-typo.patch
@@ -0,0 +1,11 @@
+--- bugle-0.0.20061109.orig/Makefile.am 2006-11-09 13:35:00.000000000 +0100
++++ bugle-0.0.20061109/Makefile.am 2006-11-09 13:35:13.000000000 +0100
+@@ -122,7 +122,7 @@
+ # ccache doesn't play nice with -fdump-translation-unit, so we disable it
+ src/data/gl.tu: src/data/gl.c src/data/overrides.h
+ $(INSTALL) -d src/data
+- CCACHE_DISPLAY=1 $(COMPILE) -fdump-translation-unit -c $(srcdir)/src/data/gl.c -o src/data/gl.o
++ CCACHE_DISABLE=1 $(COMPILE) -fdump-translation-unit -c $(srcdir)/src/data/gl.c -o src/data/gl.o
+ rm -f src/data/gl.o
+ mv gl.c.`test -f gl.c.t00.tu && echo t00.`tu src/data/gl.tu
+