summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/openliero/openliero-20080508.ebuild')
-rw-r--r--games-action/openliero/openliero-20080508.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-action/openliero/openliero-20080508.ebuild b/games-action/openliero/openliero-20080508.ebuild
new file mode 100644
index 000000000..9fbafc915
--- /dev/null
+++ b/games-action/openliero/openliero-20080508.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils games
+
+DESCRIPTION="Almost exact clone of Liero"
+HOMEPAGE="http://open.liero.be/"
+SRC_URI="http://stepien.cc/~jan/gentoo/distfiles/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}
+ || ( dev-util/jam dev-util/ftjam )"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-gcc-4.3.patch
+}
+
+src_compile() {
+ jam -qa || die "jam failed"
+}
+
+src_install() {
+ dogamesbin openliero || die "dogamesbin failed"
+ prepgamesdir
+}
+
+pkg_postinst() {
+ elog "${PN} requires the original Liero files in order to run properly."
+ elog "Visit http://www.liero.be/ and download a Liero package. Unpack it"
+ elog "and run ${PN} inside a directory with Liero."
+}