summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/retrobattle/files/retrobattle-1.0.0-build.patch')
-rw-r--r--games-arcade/retrobattle/files/retrobattle-1.0.0-build.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-arcade/retrobattle/files/retrobattle-1.0.0-build.patch b/games-arcade/retrobattle/files/retrobattle-1.0.0-build.patch
new file mode 100644
index 000000000..8ffa83a83
--- /dev/null
+++ b/games-arcade/retrobattle/files/retrobattle-1.0.0-build.patch
@@ -0,0 +1,29 @@
+Author: hasufell <hasufell@gentoo.org>
+Date: Sat Aug 4 12:15:53 2012 +0200
+
+ respect CXX, CFLAGS and LDFLAGS
+
+--- src/Makefile
++++ src/Makefile
+@@ -1,10 +1,9 @@
+-CFLAGS = `sdl-config --cflags` -g -Wall -I. -DENABLE_BINRELOC
+-CPPFLAGS = $(CFLAGS)
++CXXFLAGS += $(shell sdl-config --cflags) -I. -DENABLE_BINRELOC
+
+ # Uncomment the first LIBS line and comment out the other LIBS line to
+ # compile without SDL_Mixer
+ #LIBS = `sdl-config --libs`
+-LIBS = `sdl-config --libs` -lSDL_mixer
++LIBS = $(shell sdl-config --libs) -lSDL_mixer
+
+ RETROINSTALLDIR ?= /opt
+
+@@ -25,7 +24,7 @@
+
+
+ retrobattle: $(RETRO)
+- g++ -o $@ $^ $(LIBS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
+ mv $@ ..
+
+ clean: