summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/retrobattle/retrobattle-1.0.0.ebuild')
-rw-r--r--games-arcade/retrobattle/retrobattle-1.0.0.ebuild22
1 files changed, 16 insertions, 6 deletions
diff --git a/games-arcade/retrobattle/retrobattle-1.0.0.ebuild b/games-arcade/retrobattle/retrobattle-1.0.0.ebuild
index 5fda10409..98863eea5 100644
--- a/games-arcade/retrobattle/retrobattle-1.0.0.ebuild
+++ b/games-arcade/retrobattle/retrobattle-1.0.0.ebuild
@@ -12,21 +12,31 @@ SRC_URI="${HOMEPAGE}files/${PN}-src-${PV}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~x86"
IUSE=""
+RESTRICT="test"
RDEPEND="
- media-libs/libsdl
+ media-libs/libsdl[X,audio,video]
media-libs/sdl-mixer
"
DEPEND="${RDEPEND}"
S=${WORKDIR}/${PN}-src-${PV}/src/
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
src_install() {
- emake RETROINSTALLDIR="${D}/${GAMES_DATADIR}" install || die "emake failed"
- prepgamesdirs
- # Following games.eclass the binary should be in /usr/games/bin/
- dosym "${GAMES_DATADIR}/${PN}/${PN}" "${GAMES_PREFIX}/bin/${PN}" || die "dosym failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r "${WORKDIR}"/${PN}-src-${PV}/data
+
+ newgamesbin "${WORKDIR}"/${PN}-src-${PV}/${PN} ${PN}.bin
+ games_make_wrapper ${PN} "${PN}.bin \"${GAMES_DATADIR}/${PN}\""
+ make_desktop_entry ${PN} &{PN} ""
+
dodoc "../manual.txt" "../README"
+
+ prepgamesdirs
}