summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/lxdream/lxdream-0.8.3.ebuild')
-rw-r--r--games-emulation/lxdream/lxdream-0.8.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-emulation/lxdream/lxdream-0.8.3.ebuild b/games-emulation/lxdream/lxdream-0.8.3.ebuild
new file mode 100644
index 000000000..c6008977e
--- /dev/null
+++ b/games-emulation/lxdream/lxdream-0.8.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="1"
+
+inherit games
+
+DESCRIPTION="An emulator for the Sega Dreamcast system"
+HOMEPAGE="http://lxdream.org/"
+SRC_URI="http://${PN}.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libpng
+ media-sound/esound
+ virtual/opengl
+ x11-libs/gtk+:2"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc RELEASE_NOTES STATUS
+ newicon pixmaps/dcemu.gif lxdream.gif
+ make_desktop_entry lxdream Lxdream lxdream || die "make_desktop_entry failed"
+ prepgamesdirs
+}