summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/postal2mp/postal2mp-1409.ebuild')
-rw-r--r--games-fps/postal2mp/postal2mp-1409.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-fps/postal2mp/postal2mp-1409.ebuild b/games-fps/postal2mp/postal2mp-1409.ebuild
new file mode 100644
index 000000000..a7def7c8c
--- /dev/null
+++ b/games-fps/postal2mp/postal2mp-1409.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Postal 2: Share the Pain - Free Multiplayer Edition"
+HOMEPAGE="http://icculus.org/news/news.php?id=4419"
+SRC_URI="http://0day.icculus.org/postal2/Postal2STP-FreeMP-linux.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="postal2stp-freemp"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RESTRICT="strip"
+PROPERTIES="interactive"
+
+RDEPEND="virtual/opengl
+ media-libs/libsdl[X,opengl]
+ media-libs/openal"
+
+GAMES_CHECK_LICENSE="yes"
+
+S=${WORKDIR}/Postal2STP-FreeMP-linux
+
+src_install() {
+ dir=${GAMES_PREFIX_OPT}/${PN}
+
+ insinto "${dir}"
+ doins -r Animations KarmaData Maps Music Sounds \
+ StaticMeshes System Textures Web || die "doins failed"
+ dosym /usr/lib/libopenal.so "${dir}"/System/openal.so || die
+ dosym /usr/lib/libSDL-1.2.so.0 "${dir}"/System/libSDL-1.2.so.0 || die
+
+ fperms +x "${dir}"/System/postal2-bin || die "fperms failed"
+
+ games_make_wrapper ${PN} ./postal2-bin "${dir}"/System .
+ newicon postal2.xpm ${PN}.xpm || die
+ make_desktop_entry ${PN} "Postal 2 (Free MultiPlayer Ed.)"
+
+ prepgamesdirs
+}