summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/limbs-off/limbs-off-1.0_alpha2.ebuild')
-rw-r--r--games-misc/limbs-off/limbs-off-1.0_alpha2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/games-misc/limbs-off/limbs-off-1.0_alpha2.ebuild b/games-misc/limbs-off/limbs-off-1.0_alpha2.ebuild
new file mode 100644
index 000000000..12ecfa166
--- /dev/null
+++ b/games-misc/limbs-off/limbs-off-1.0_alpha2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit autotools git-2 games
+
+DESCRIPTION="Gratis Free Software fighting game"
+HOMEPAGE="http://plaimi.net/games/"
+EGIT_REPO_URI="https://github.com/stiell/${PN}.git
+ git://github.com/stiell/${PN}.git"
+EGIT_COMMIT="c402478ff4c93caa75219527e0a59ae5061ce66f"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="
+ media-libs/fontconfig
+ media-libs/libpng:0
+ media-libs/libsdl
+ media-libs/sdl-ttf
+ virtual/opengl
+ "
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ "
+
+src_unpack() {
+ git-2_src_unpack
+}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --with-icondir=/usr/share/pixmaps \
+ --with-desktopdir=/usr/share/applications
+}
+
+src_install() {
+ dodoc HACKING TODO || die
+ emake DESTDIR="${D}" install || die
+ prepgamesdirs
+}