summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/fotoxx/fotoxx-5.3.1.ebuild')
-rw-r--r--media-gfx/fotoxx/fotoxx-5.3.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-gfx/fotoxx/fotoxx-5.3.1.ebuild b/media-gfx/fotoxx/fotoxx-5.3.1.ebuild
new file mode 100644
index 000000000..36b2fa241
--- /dev/null
+++ b/media-gfx/fotoxx/fotoxx-5.3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Program for improving image files made with a digital camera."
+HOMEPAGE="http://kornelix.squarespace.com/fotoxx"
+SRC_URI="http://kornelix.squarespace.com/storage/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/gtk+-2.8"
+RDEPEND="${DEPEND}
+ media-gfx/exiv2
+ >=media-gfx/printoxx-1.2"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ emake PREFIX=/usr || die "build failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install || die "emake install failed"
+ make_desktop_entry ${PN} "Fotoxx" /usr/share/${PN}/icons/${PN}.png "Application;Graphics;2DGraphics;"
+}