summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/bellagio/bellagio-0.9.1.ebuild')
-rw-r--r--media-libs/bellagio/bellagio-0.9.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-libs/bellagio/bellagio-0.9.1.ebuild b/media-libs/bellagio/bellagio-0.9.1.ebuild
new file mode 100644
index 000000000..4d8c6b9b3
--- /dev/null
+++ b/media-libs/bellagio/bellagio-0.9.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="An Open Source implementation of the OpenMAX Integration Layer"
+HOMEPAGE="http://omxil.sourceforge.net"
+SRC_URI="mirror://sourceforge/omxil/libomxil-${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="alsa doc fbcon ffmpeg jpeg mad vorbis"
+
+RDEPEND="media-libs/alsa-lib
+ mad? ( media-libs/libmad )
+ vorbis? ( media-libs/libvorbis )
+ ffmpeg? ( media-video/ffmpeg )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/libomxil-${P}"
+
+src_compile() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable alsa) \
+ $(use_enable doc) \
+ $(use_enable fbcon fbvideosink) \
+ $(use_enable ffmpeg ffmpegcomponents) \
+ $(use_enable jpeg) \
+ $(use_enable mad madcomponents) \
+ $(use_enable vorbis vorbiscomponents)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog || die "dodoc failed"
+}