summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio/dxcc/dxcc-20080225.ebuild')
-rw-r--r--media-radio/dxcc/dxcc-20080225.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-radio/dxcc/dxcc-20080225.ebuild b/media-radio/dxcc/dxcc-20080225.ebuild
new file mode 100644
index 000000000..2be138b99
--- /dev/null
+++ b/media-radio/dxcc/dxcc-20080225.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="A ham radio callsign DXCC lookup utility"
+HOMEPAGE="http://fkurz.net/ham/dxcc.html"
+SRC_URI="http://fkurz.net/ham/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="tk"
+
+RDEPEND="dev-lang/perl
+ tk? ( dev-perl/perl-tk )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/Makefile.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}/usr" install || die "emake failed"
+ doman dxcc.1 || die "doman failed"
+ dodoc README ChangeLog || die "dodoc failed"
+}