summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio/rivendell')
-rw-r--r--media-radio/rivendell/ChangeLog10
-rw-r--r--media-radio/rivendell/Manifest6
-rw-r--r--media-radio/rivendell/files/rivendell-1.2.1-init.patch24
-rw-r--r--media-radio/rivendell/files/rivendell-1.2.1-sandbox.patch22
-rw-r--r--media-radio/rivendell/metadata.xml20
-rw-r--r--media-radio/rivendell/rivendell-1.2.1.ebuild80
6 files changed, 162 insertions, 0 deletions
diff --git a/media-radio/rivendell/ChangeLog b/media-radio/rivendell/ChangeLog
new file mode 100644
index 000000000..aab8b0454
--- /dev/null
+++ b/media-radio/rivendell/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-radio/rivendell
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 11 Jan 2009; Emery Hemingway <emery@lcom.net> +rivendell-1.2.1.ebuild,
+ +files/rivendell-1.2.1-init.patch, +files/rivendell-1.2.1-sandbox.patch,
+ +metadata.xml:
+ New ebuild for Rivendell, bug 24505. Thanks be to Ycarus, #gentoo-sunrise,
+ and the incomprable Fred Gleason.
+
diff --git a/media-radio/rivendell/Manifest b/media-radio/rivendell/Manifest
new file mode 100644
index 000000000..fef71cec0
--- /dev/null
+++ b/media-radio/rivendell/Manifest
@@ -0,0 +1,6 @@
+AUX rivendell-1.2.1-init.patch 852 RMD160 60d28b0d88e7fe86d2ccb24b80255e807893805c SHA1 ed8d8673b4b556510e1214ee06a23ccbcca20311 SHA256 9577f041e488f48dd72810af85c7703efb11f8a0f339a5cc74942b826a2c2246
+AUX rivendell-1.2.1-sandbox.patch 717 RMD160 abda7f0c90eb730f9d11d89ce6ba4e15ba637ae3 SHA1 c88ecf1e2d07e0c5c2656d29f1efbdc67d974391 SHA256 f36c2a355471a2a5fd00a0d2dc26f1f85136236cd60caa9d61e6b8d1ba6aded8
+DIST rivendell-1.2.1.tar.gz 2084108 RMD160 2da05c0c9647e1bf987271a1cbbf7cca03175bbd SHA1 23163a27539afb2089ff6c11eae92658a59132bb SHA256 5f71f77d5d4d7c53c84d912651cafca613473c9cdbc48c4fc3612332deaf9f11
+EBUILD rivendell-1.2.1.ebuild 2068 RMD160 0d5e39b47c7a029e58ce8f14db95f78a4002a0e7 SHA1 1541bdb5febdc37c1916dcc57e51a07461af7f47 SHA256 c006fd66a297708c7ec28c7f08e29c8b718061dc887a67a2bdcb30383136759f
+MISC ChangeLog 401 RMD160 616b8999d76077fca3b9f5154b5518010b8d4d32 SHA1 1c1cafd40b4d24931373741fec6f9d5821cf0c75 SHA256 f1ccb0669b1229cce30f2a52d2edd4d0386223b6f3779e2af7cd6421c4209c1a
+MISC metadata.xml 1016 RMD160 fb111ed311547d2ebadcc9bb886db49bac9e8a98 SHA1 45a008d264a38e08fa09699378a3b4658ed52a23 SHA256 04f54315c647fddbdb740e492010889715556a9071751c31a5591a92c46854d4
diff --git a/media-radio/rivendell/files/rivendell-1.2.1-init.patch b/media-radio/rivendell/files/rivendell-1.2.1-init.patch
new file mode 100644
index 000000000..f5dd2e6f4
--- /dev/null
+++ b/media-radio/rivendell/files/rivendell-1.2.1-init.patch
@@ -0,0 +1,24 @@
+## Fixes jack depend and reduces daemons permissions
+--- /usr/src/rivendell-1.2.1/rivendell-gentoo 2007-10-05 09:31:21.000000000 -0500
++++ /etc/init.d/rivendell 2009-01-10 07:24:04.226186550 -0600
+@@ -26,17 +26,16 @@
+ ##
+
+ depend() {
+- need jackd
+ use mysql
+ }
+
+ start() {
+ ebegin "Starting Rivendell"
+ ipcrm -M 0x5005 2> /dev/null
+- start-stop-daemon --start --quiet --exec /usr/bin/caed
+- start-stop-daemon --start --quiet --exec /usr/bin/ripcd
++ start-stop-daemon --start --quiet --chuid rivendell --exec /usr/bin/caed
++ start-stop-daemon --start --quiet --chuid rivendell --exec /usr/bin/ripcd
+ sleep 1
+- start-stop-daemon --start --quiet --exec /usr/bin/rdcatchd
++ start-stop-daemon --start --quiet --chuid rivendell --exec /usr/bin/rdcatchd
+ eend $?
+ }
+
diff --git a/media-radio/rivendell/files/rivendell-1.2.1-sandbox.patch b/media-radio/rivendell/files/rivendell-1.2.1-sandbox.patch
new file mode 100644
index 000000000..2f2c7269a
--- /dev/null
+++ b/media-radio/rivendell/files/rivendell-1.2.1-sandbox.patch
@@ -0,0 +1,22 @@
+# This keeps the install script from playing outside the sandbox
+--- install-init.sh 2007-10-03 06:24:06.000000000 -0500
++++ install-init.sh.new 2009-01-09 00:04:14.000000000 -0600
+@@ -23,12 +23,12 @@
+ #
+
+ if test ! -f ./building-debian ; then
+- mkdir -p /etc/init.d
+- cp rivendell /etc/init.d/rivendell
+- mkdir -p /etc/sysconfig
+- cp rivendell.sys /etc/sysconfig/rivendell
+- mkdir -p /var/run/rivendell
+- chmod 777 /var/run/rivendell
++ mkdir -p ${DESTDIR}/etc/init.d
++ cp rivendell ${DESTDIR}/etc/init.d/rivendell
++ mkdir -p ${DESTDIR}/etc/sysconfig
++ cp rivendell.sys ${DESTDIR}/etc/sysconfig/rivendell
++ mkdir -p ${DESTDIR}/var/run/rivendell
++ chmod 777 ${DESTDIR}/var/run/rivendell
+ ldconfig
+ fi
+
diff --git a/media-radio/rivendell/metadata.xml b/media-radio/rivendell/metadata.xml
new file mode 100644
index 000000000..36f816ce5
--- /dev/null
+++ b/media-radio/rivendell/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>maintainer-wanted@gentoo.org</email>
+</maintainer>
+<!-- <longdescription>
+ Rivendell is a complete radio broadcast automation solution, with facilities
+ for the acquisition, management, scheduling and playout of audio content. It
+ has all of the features one would expect in a modern, fully-fledged radio
+ automation system, including support for both PCM and MPEG audio encoding, full
+ voicetracking and log customization as well as support for a wide variety of
+ third party software and hardware. As a robust, functionally complete digital
+ audio system for broadcast radio applications, Rivendell uses industry standard
+ components like the GNU/Linux Operating System, the AudioScience HPI Driver
+ Architecture and the MySQL Database Engine. Rivendell is available under the
+ GNU Public License.
+</longdescription> -->
+</pkgmetadata>
diff --git a/media-radio/rivendell/rivendell-1.2.1.ebuild b/media-radio/rivendell/rivendell-1.2.1.ebuild
new file mode 100644
index 000000000..c9ce6c0dc
--- /dev/null
+++ b/media-radio/rivendell/rivendell-1.2.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="1"
+inherit eutils
+
+DESCRIPTION="An automated system for acquisition, management, scheduling and playout of audio content."
+HOMEPAGE="http://rivendellaudio.org/"
+SRC_URI="http://rivendellaudio.org/ftpdocs/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa jack pam"
+
+DEPEND="alsa? ( media-libs/alsa-lib )
+ jack? ( media-sound/jack-audio-connection-kit )
+ media-libs/flac
+ media-libs/id3lib
+ media-libs/libogg
+ media-libs/libsamplerate
+ media-libs/libvorbis
+ virtual/mysql
+ x11-libs/qt:3"
+RDEPEND="pam? ( sys-libs/pam )
+ app-cdr/cdrtools
+ media-sound/cdparanoia
+ media-sound/mpg321
+ media-sound/sox
+ media-sound/vorbis-tools
+ net-ftp/lftp
+ net-misc/wget
+ sys-devel/bc"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN},audio
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-init.patch"
+ epatch "${FILESDIR}/${P}-sandbox.patch"
+}
+
+src_compile() {
+ local myconf=""
+ use alsa || myconf="${myconf} --disable-alsa"
+ use jack || myconf="${myconf} --disable-jack"
+ use pam || myconf="${myconf} --disable-pam"
+ econf ${myconf}
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ insinto /etc
+ doins conf/rd.conf-sample || die
+ keepdir /var/snd || die
+ fowners ${PN}:${PN} /var/snd || die
+ dodoc AUTHORS ChangeLog NEWS README SupportedCards docs/*.txt || die
+ prepalldocs
+}
+
+pkg_postinst() {
+ elog "If you would like ASI or GPIO hardware support, install"
+ elog "their drivers and re-emerge this package. If you would"
+ elog "like the RDFeed RSS Podcast module to work, you'll need"
+ elog "www-servers/apache"
+ echo
+ einfo "If this is a fresh install you will need to modify"
+ einfo "the /etc/rd.conf file and use rdadmin to initialize"
+ einfo "the Rivendell database. Don't forget to make sure you"
+ einfo "start /etc/init.d/rivendell."
+ echo
+ ewarn "If this is an upgrade, run rdadmin to ensure your"
+ ewarn "database schema is up to date"
+}