summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/mtag/mtag-3.ebuild')
-rw-r--r--media-sound/mtag/mtag-3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-sound/mtag/mtag-3.ebuild b/media-sound/mtag/mtag-3.ebuild
new file mode 100644
index 000000000..146d960d3
--- /dev/null
+++ b/media-sound/mtag/mtag-3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="the fast media tag lib"
+HOMEPAGE="http://mtag.berlios.de/"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="media-libs/taglib
+ >=dev-db/sqlite-3.3.12"
+DEPEND="dev-util/cmake
+ ${RDEPEND}"
+
+src_compile() {
+ cmake "${S}" || die "compile failed!"
+ emake || die "compile failed!"
+}
+
+src_install() {
+ dobin mtag
+ dodoc README ChangeLog AUTHORS
+ if use doc; then
+ dohtml html/*
+ fi
+}