summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/mtag/mtag-9999.ebuild')
-rw-r--r--media-sound/mtag/mtag-9999.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/media-sound/mtag/mtag-9999.ebuild b/media-sound/mtag/mtag-9999.ebuild
index f25c2e5ce..3e65b608a 100644
--- a/media-sound/mtag/mtag-9999.ebuild
+++ b/media-sound/mtag/mtag-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit eutils subversion
+inherit cmake-utils subversion
DESCRIPTION="the fast media tag lib"
HOMEPAGE="http://mtag.berlios.de/"
@@ -16,22 +16,22 @@ IUSE="doc"
RDEPEND="media-libs/taglib
>=dev-db/sqlite-3.3.12"
-DEPEND="dev-util/cmake
- doc? ( app-doc/doxygen )
+DEPEND="doc? ( app-doc/doxygen )
${RDEPEND}"
+CMAKE_IN_SOURCE_BUILD=1
+
src_compile() {
- cmake "${S}" || die "compile failed!"
- emake || die "compile failed!"
+ cmake-utils_src_compile
if use doc; then
doxygen "${S}" || die "compile failed!"
fi
}
src_install() {
- dobin mtag
- dodoc README ChangeLog AUTHORS
+ dobin mtag || die "dobin failed"
+ dodoc README ChangeLog AUTHORS || die "dodoc failed"
if use doc; then
- dohtml html/*
+ dohtml -r html/* || die "dohtml failed"
fi
}