summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/ripoff/ripoff-0.8.1.ebuild')
-rw-r--r--media-sound/ripoff/ripoff-0.8.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-sound/ripoff/ripoff-0.8.1.ebuild b/media-sound/ripoff/ripoff-0.8.1.ebuild
new file mode 100644
index 000000000..badcd6a51
--- /dev/null
+++ b/media-sound/ripoff/ripoff-0.8.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Simple GTK+ Based CD Ripper"
+HOMEPAGE="http://ripoffc.sourceforge.net"
+SRC_URI="mirror://sourceforge/ripoffc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vorbis mp3 flac"
+RDEPEND=">=x11-libs/gtk+-2.4
+ dev-libs/libcdio
+ media-libs/libcddb
+ vorbis? ( media-libs/libvorbis )
+ mp3? ( media-sound/lame )
+ flac? ( media-libs/flac )"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ econf \
+ $(use_enable vorbis) \
+ $(use_enable mp3) \
+ $(use_enable flac) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO
+}