summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/divxcalc/divxcalc-0.6.ebuild')
-rw-r--r--media-video/divxcalc/divxcalc-0.6.ebuild20
1 files changed, 15 insertions, 5 deletions
diff --git a/media-video/divxcalc/divxcalc-0.6.ebuild b/media-video/divxcalc/divxcalc-0.6.ebuild
index 463f69235..e958b87fb 100644
--- a/media-video/divxcalc/divxcalc-0.6.ebuild
+++ b/media-video/divxcalc/divxcalc-0.6.ebuild
@@ -2,26 +2,36 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+inherit autotools eutils
+
DESCRIPTION="A simple MPEG-4 bitrate calculator used when ripping a DVD to achieve the ideal filesize."
-HOMEPAGE="http://axljab.homelinux.org/DivXcalc"
-SRC_URI="http://www.imagef1.net.nz/${PN}/${P}.tar.bz2
+HOMEPAGE="http://axllent.org/projects/divxcalc/files/"
+SRC_URI="http://axllent.org/projects/${PN}/files/${P}.tar.bz2
+ http://www.imagef1.net.nz/${PN}/${P}.tar.bz2
http://mirror.dannz.net/${PN}/${P}.tar.bz2"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="=x11-libs/qt-3*"
DEPEND="${RDEPEND}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-build.patch"
+ cp admin/acinclude.m4.in acinclude.m4
+ eautoreconf
+}
+
src_compile() {
- emake -f Makefile.dist
econf || die "econf failed"
emake || die "emake failed"
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
- dodoc NEWS README
+ dodoc README
}