summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/nsd/nsd-3.2.15.ebuild')
-rw-r--r--net-dns/nsd/nsd-3.2.15.ebuild86
1 files changed, 0 insertions, 86 deletions
diff --git a/net-dns/nsd/nsd-3.2.15.ebuild b/net-dns/nsd/nsd-3.2.15.ebuild
deleted file mode 100644
index 121143997..000000000
--- a/net-dns/nsd/nsd-3.2.15.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-
-inherit user versionator
-
-DESCRIPTION="An authoritative only, high performance, open source name server"
-HOMEPAGE="http://www.nlnetlabs.nl/projects/nsd"
-SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="bind8-stats ipv6 minimal-responses mmap +nsec3 ratelimit root-server runtime-checks zone-stats"
-
-RDEPEND="
- dev-libs/openssl
- virtual/yacc
-"
-DEPEND="
- ${RDEPEND}
- sys-devel/flex
-"
-
-pkg_setup() {
- enewgroup nsd
- enewuser nsd -1 -1 -1 nsd
-}
-
-src_configure() {
- # ebuild.sh sets localstatedir to /var/lib, but nsd expects /var in several locations
- # some of these cannot be changed by arguments to econf/configure, f.i. logfile
- econf \
- --localstatedir="${EPREFIX}/var" \
- --with-pidfile="${EPREFIX}/var/run/nsd/nsd.pid" \
- --with-zonesdir="${EPREFIX}/var/lib/nsd" \
- --enable-largefile \
- $(use_enable bind8-stats) \
- $(use_enable ipv6) \
- $(use_enable minimal-responses) \
- $(use_enable mmap) \
- $(use_enable nsec3) \
- $(use_enable ratelimit) \
- $(use_enable root-server) \
- $(use_enable runtime-checks checking) \
- $(use_enable zone-stats)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- dodoc doc/{ChangeLog,CREDITS,NSD-FOR-BIND-USERS,README,RELNOTES,REQUIREMENTS}
-
- insinto /usr/share/nsd
- doins contrib/nsd.zones2nsd.conf
-
- exeinto /etc/cron.daily
- doexe "${FILESDIR}"/nsd.cron
-
- newinitd "${FILESDIR}"/nsd.initd nsd
- newconfd "${FILESDIR}"/nsd.confd nsd
-
- # database directory, writable by nsd for ixfr.db file
- dodir /var/db/nsd
- fowners nsd:nsd /var/db/nsd
- fperms 750 /var/db/nsd
-
- # zones directory, writable by root for 'nsdc patch'
- dodir /var/lib/nsd
- fowners root:nsd /var/lib/nsd
- fperms 750 /var/lib/nsd
-
- # remove /var/run data created by Makefile, handled by initd script
- rm -r "${D}"/var/run || die "could not remove /var/run/ directory"
-
-}
-
-pkg_postinst() {
- version_compare "3.2.9" "${REPLACING_VERSIONS}"
- if test $? -eq 3; then
- ewarn "In ${PN}-3.2.9, the database format was changed."
- ewarn "Please run '/etc/init.d/nsd rebuild' to rebuild the database, then restart nsd."
- fi
-}