summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/ftpd/ftpd-0.17-r4.ebuild')
-rw-r--r--net-ftp/ftpd/ftpd-0.17-r4.ebuild21
1 files changed, 8 insertions, 13 deletions
diff --git a/net-ftp/ftpd/ftpd-0.17-r4.ebuild b/net-ftp/ftpd/ftpd-0.17-r4.ebuild
index 6be28eff2..a8d0c0756 100644
--- a/net-ftp/ftpd/ftpd-0.17-r4.ebuild
+++ b/net-ftp/ftpd/ftpd-0.17-r4.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpd/ftpd-0.17-r3.ebuild,v 1.5 2005/11/11 15:43:40 blubb Exp $
+# $Header: $
inherit eutils ssl-cert
-
DESCRIPTION="The netkit FTP server with optional SSL support"
HOMEPAGE="http://www.hcs.harvard.edu/~dholland/computers/netkit.html"
SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/linux-${P}.tar.gz
@@ -20,18 +19,16 @@ DEPEND="ssl? ( dev-libs/openssl )"
RDEPEND="${DEPEND}
virtual/inetd"
-S="${WORKDIR}"/linux-${P}
+S=${WORKDIR}/linux-${P}
src_unpack() {
unpack ${A}
cd "${S}"
- if use ssl; then
- epatch "${DISTDIR}"/linux-${P}-ssl.patch
- fi
- epatch "${FILESDIR}"/${P}-shadowfix.patch
+ use ssl && epatch "${DISTDIR}/linux-${P}-ssl.patch"
+ epatch "${FILESDIR}/${P}-shadowfix.patch"
# fixes gcc 4.1 compatibility
- epatch "${FILESDIR}"/${P}-gcc41.patch
+ epatch "${FILESDIR}/${P}-gcc41.patch"
}
src_compile() {
@@ -46,17 +43,15 @@ src_install() {
doman ftpd/ftpd.8
dodoc README ChangeLog
insinto /etc/xinetd.d
- newins "${FILESDIR}"/ftp.xinetd ftp
- if use ssl;
- then
+ newins "${FILESDIR}/ftp.xinetd" ftp
+ if use ssl; then
insinto /etc/ssl/certs/
docert ftpd
fi
}
pkg_postinst() {
- if use ssl;
- then
+ if use ssl; then
einfo "In order to start the server with SSL support"
einfo "You need a certificate /etc/ssl/certs/ftpd.pem."
einfo "A temporary certificiate has been created."