summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/fec/fec-1.0.3-r1.ebuild')
-rw-r--r--net-libs/fec/fec-1.0.3-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/fec/fec-1.0.3-r1.ebuild b/net-libs/fec/fec-1.0.3-r1.ebuild
new file mode 100644
index 000000000..580b23c89
--- /dev/null
+++ b/net-libs/fec/fec-1.0.3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils flag-o-matic java-pkg-2 toolchain-funcs
+
+DESCRIPTION="Forward error correction libs"
+HOMEPAGE="http://www.onionnetworks.com/developers/"
+SRC_URI="http://www.onionnetworks.com/downloads/${P}.zip
+ http://dev.gentooexperimental.org/~tommy/distfiles/${P}.zip"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip"
+S=${WORKDIR}/${P}/src/csrc/
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/Makefile.patch
+}
+
+src_compile() {
+ append-flags -fPIC
+ tc-export CC
+ emake || die
+}
+
+src_install() {
+ dolib.so ../../lib/fec-linux-x86/lib/linux/x86/libfec{8,16}.so
+}