summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/rb_libtorrent/rb_libtorrent-0.11_rc1.ebuild')
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.11_rc1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.11_rc1.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.11_rc1.ebuild
new file mode 100644
index 000000000..9b9b45ffc
--- /dev/null
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.11_rc1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+inherit eutils autotools
+
+DESCRIPTION="BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
+SRC_URI="http://www.rasterbar.com/products/libtorrent/libtorrent-0.11-rc1.tar.gz"
+
+MY_PN="${PN/rb_/}"
+MY_PV="${PV/_rc1/}"
+S=${WORKDIR}/${MY_PN}-${MY_PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="dev-libs/boost"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ # If threads were used to build boost, the library files will have a suffix.
+ if built_with_use "dev-libs/boost" threads || use built_with_use "dev-libs/boost" threads-only ; then
+ BOOST_LIBS="--with-boost-date-time=mt --with-boost-filesystem=mt --with-boost-thread=mt --with-boost-regex=mt --with-boost-program_options=mt"
+ else
+ die "rb_libtorrent needs dev-libs/boost built with threads USE flag"
+ fi
+
+ econf $(use_enable debug) ${BOOST_LIBS} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS README
+}