summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/notmuch/ChangeLog8
-rw-r--r--net-mail/notmuch/Manifest4
-rw-r--r--net-mail/notmuch/metadata.xml6
-rw-r--r--net-mail/notmuch/notmuch-0.3.1.ebuild64
4 files changed, 82 insertions, 0 deletions
diff --git a/net-mail/notmuch/ChangeLog b/net-mail/notmuch/ChangeLog
new file mode 100644
index 000000000..84f3aa7c5
--- /dev/null
+++ b/net-mail/notmuch/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-mail/notmuch
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 09 May 2010; Cédric Cabessa (ced_c) <ced@ryick.net>
+ +notmuch-0.3.1.ebuild, +metadata.xml:
+ New ebuild for notmuch, bug #318499. Many thanks to Tommy[D] and Ramonster
+
diff --git a/net-mail/notmuch/Manifest b/net-mail/notmuch/Manifest
new file mode 100644
index 000000000..2130ff763
--- /dev/null
+++ b/net-mail/notmuch/Manifest
@@ -0,0 +1,4 @@
+DIST notmuch-0.3.1.tar.gz 239839 RMD160 081f29d0ff875296f8491289895d3b6b378c9e18 SHA1 a59820085c44229843684d81fbfbbed473956a12 SHA256 870c3d2cddb200a1c57fa7735cf19983de6e5856038a877f6e4403b5f41ca4e2
+EBUILD notmuch-0.3.1.ebuild 1293 RMD160 1f8a45e845c5b178f3afc804a4760de3bef7c95f SHA1 1852987113335ea3f0a1e33491ec2e50a1ae4cef SHA256 5676567fb02e4da4319b5c4b3403923bec208e64a31b25e00ce860793b354f88
+MISC ChangeLog 290 RMD160 456a6e020cbe7048beca5c1e14ef68e63ef65227 SHA1 4422ec879b05948b938c3f93ad22bf22722a7664 SHA256 0d8d601325839e258f196f0e86420d1f2dd17f1d19ca52914fa13055de3c455b
+MISC metadata.xml 229 RMD160 f0f6417bec31ce8baba6d476664f7210c8c84c98 SHA1 e5f94f5caadc6f843fc90bb7959570cd503676fd SHA256 3b08fca3c878bdfc4e7639f477dd542d55a4ab5dce39a475e82633071d13eb3f
diff --git a/net-mail/notmuch/metadata.xml b/net-mail/notmuch/metadata.xml
new file mode 100644
index 000000000..e6233b5dc
--- /dev/null
+++ b/net-mail/notmuch/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer><email>maintainer-wanted@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/net-mail/notmuch/notmuch-0.3.1.ebuild b/net-mail/notmuch/notmuch-0.3.1.ebuild
new file mode 100644
index 000000000..35ff6b2fa
--- /dev/null
+++ b/net-mail/notmuch/notmuch-0.3.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+PYTHON_DEPEND="python? 2:2.6"
+
+inherit distutils
+
+DESCRIPTION="Thread-based email index, search and tagging"
+HOMEPAGE="http://notmuchmail.org/"
+SRC_URI="http://notmuchmail.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python"
+
+DEPEND="dev-libs/gmime:2.4
+ sys-libs/talloc
+ >=dev-libs/xapian-1.0.19
+ "
+RDEPEND="${DEPEND}"
+
+#This is need for src_compile and src_install:
+#setup.py imports the notmuch module (__init__.py), which looks for
+#libnotmuch.so
+export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:${S}/lib
+
+src_prepare() {
+ if use python ; then
+ cd bindings/python || die "bindings/python not found"
+ distutils_src_prepare
+ fi
+}
+
+src_compile() {
+ default
+ if use python ; then
+ cd bindings/python || die "bindings/python not found"
+ distutils_src_compile
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake failed"
+ dodoc AUTHORS NEWS README TODO || die "dodoc failed"
+ if use python ; then
+ cd bindings/python || die "bindings/python not found"
+ distutils_src_install
+ fi
+}
+
+pkg_postinst() {
+ if use python ; then
+ distutils_pkg_postinst
+ fi
+}
+
+pkg_postrm() {
+ if use python ; then
+ distutils_pkg_postrm
+ fi
+}