summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/anyremote/anyremote-4.18.1.ebuild')
-rw-r--r--net-misc/anyremote/anyremote-4.18.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/anyremote/anyremote-4.18.1.ebuild b/net-misc/anyremote/anyremote-4.18.1.ebuild
new file mode 100644
index 000000000..344a3967f
--- /dev/null
+++ b/net-misc/anyremote/anyremote-4.18.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+DESCRIPTION="Anyremote provides wireless Bluetooth or infrared remote control service, but works also with cable"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth gnome kde"
+
+RDEPEND="bluetooth? ( || ( ( net-wireless/bluez-libs net-wireless/bluez-utils ) net-wireless/bluez ) )
+ x11-libs/libXtst"
+
+DEPEND="${RDEPEND}"
+
+PDEPEND="kde? ( net-misc/kanyremote )
+ gnome? ( net-misc/ganyremote )"
+
+src_configure() {
+ econf $(use_enable bluetooth)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "install doc failed"
+}