summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/gns3/gns3-0.7.2.ebuild')
-rw-r--r--net-misc/gns3/gns3-0.7.2.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/net-misc/gns3/gns3-0.7.2.ebuild b/net-misc/gns3/gns3-0.7.2.ebuild
deleted file mode 100644
index edd941bc1..000000000
--- a/net-misc/gns3/gns3-0.7.2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=2
-
-PYTHON_DEPEND="2"
-
-inherit eutils python distutils
-
-MY_P=${P/gns/GNS}-src
-
-DESCRIPTION="Graphical Network Simulator"
-HOMEPAGE="http://www.gns3.net/"
-SRC_URI="mirror://sourceforge/gns-3/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=">=dev-python/PyQt4-4.6.1
- x11-libs/qt-gui:4
- x11-libs/qt-svg:4"
-RDEPEND="${DEPEND}
- >=app-emulation/dynamips-0.2.8_rc2"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${P}_set_dynamips_path.patch"
- epatch "${FILESDIR}/${P}_set_qemu_path.patch"
-
- python_convert_shebangs -r 2 .
-
- distutils_src_prepare
-}
-
-src_install() {
- distutils_src_install
-
- insinto /usr/libexec/${PN}
- doins qemuwrapper/{pemubin,qemuwrapper}.py || die
-
- doicon "${FILESDIR}"/${PN}.xpm
- make_desktop_entry ${PN} "GNS3" ${PN} "Utility;Emulator"
-
- doman docs/man/${PN}.1 || die
-}