summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/kanyremote/kanyremote-5.5.1.ebuild')
-rw-r--r--net-misc/kanyremote/kanyremote-5.5.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/kanyremote/kanyremote-5.5.1.ebuild b/net-misc/kanyremote/kanyremote-5.5.1.ebuild
new file mode 100644
index 000000000..07875e0fb
--- /dev/null
+++ b/net-misc/kanyremote/kanyremote-5.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="KDE frontend to Anyremote"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/anyremote/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=" >=net-misc/anyremote-4.4
+ >=dev-python/PyQt-3.17
+ >=dev-python/pykde-3.16"
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ make_desktop_entry ${PN} ${PN} ${PN}.png "Network;RemoteAccess"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}
+
+pkg_postinst() {
+ if ! built_with_use net-misc/anyremote bluetooth ; then
+ elog
+ elog "If you want to use bluetooth with kanyremote, you need to"
+ elog "compile net-misc/anyremote with bluetooth use flag."
+ fi
+}
+