summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/mugshot/mugshot-1.1.58.ebuild')
-rw-r--r--net-misc/mugshot/mugshot-1.1.58.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/net-misc/mugshot/mugshot-1.1.58.ebuild b/net-misc/mugshot/mugshot-1.1.58.ebuild
index 29708c5a0..929a255d0 100644
--- a/net-misc/mugshot/mugshot-1.1.58.ebuild
+++ b/net-misc/mugshot/mugshot-1.1.58.ebuild
@@ -53,9 +53,13 @@ src_unpack() {
else
G2CONF="${G2CONF} --with-gecko-sdk=/usr/$(get_libdir)/mozilla-firefox"
fi
+
+ # use the correct libdir in the firefox-update.sh script
sed -e "s:GET_LIBDIR:$(get_libdir):" \
"${FILESDIR}/${P}-firefox-update.sh" > "${S}/firefox-update.sh"
- # support mozilla-firefox-bin if we are compiling for x86
+
+ # add support for (32-bit) mozilla-firefox-bin if our profile is
+ # x86 or amd64 with a 32-bit userland
if [ "${ARCH}" = "x86" -o "${ABI}" = "x86" ] ; then
FIREDIRS="${FIREDIRS} /opt/firefox"
fi