summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/cloudvpn/ChangeLog4
-rw-r--r--net-misc/cloudvpn/Manifest4
-rw-r--r--net-misc/cloudvpn/cloudvpn-1.0.9.ebuild26
3 files changed, 33 insertions, 1 deletions
diff --git a/net-misc/cloudvpn/ChangeLog b/net-misc/cloudvpn/ChangeLog
index 83ebd00fd..b4eb47d6b 100644
--- a/net-misc/cloudvpn/ChangeLog
+++ b/net-misc/cloudvpn/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 19 Apr 2009; Mirek Kratochvil ([exa]) <exa.exa@gmail.com>
+ +cloudvpn-1.0.9.ebuild:
+ version bump for bug 258859
+
13 Feb 2009; Mirek Kratochvil ([exa]) <exa.exa@gmail.com>
+cloudvpn-1.0.7.ebuild, +metadata.xml:
new ebuild for bug #258859
diff --git a/net-misc/cloudvpn/Manifest b/net-misc/cloudvpn/Manifest
index d92e657c5..f374fcdde 100644
--- a/net-misc/cloudvpn/Manifest
+++ b/net-misc/cloudvpn/Manifest
@@ -1,4 +1,6 @@
DIST cloudvpn-1.0.7.tar.bz2 63901 RMD160 f5de88ab5c797d6b6076b7d8f9b18e1de11bf8f6 SHA1 c5988a61615a802eb25d8ca4dfd00dca6c17d9e5 SHA256 75be08532ebeafcaad2bce144af1c401af9df9ec49be173b1ee037af37899ea0
+DIST cloudvpn-1.0.9.tar.bz2 67073 RMD160 f450e5106bff8bea71e069b0f15284ac253b8ef2 SHA1 f4253ff13d8c3df783ab84040d69b5a27d6553cf SHA256 47125c67f95e3ddf54e0703f01b46995f98afabfc17d9d5b8c874a5be5e6eec4
EBUILD cloudvpn-1.0.7.ebuild 596 RMD160 98777e995dc87eaf847f76ea7e0ea74eb9d9a05e SHA1 a5ad268263aa57657d5f8e6b0cd96221c292454a SHA256 86a146ce7c12ce4aa58e85074a2a5f2ebd7690bc94fda8388bf5d069fd09a1b5
-MISC ChangeLog 249 RMD160 6c08f8dd66f4fd9fe657637e491375ba73461f6a SHA1 6785bef091fffe2c6f7a7dd963dea4900b2ed6e5 SHA256 952e4d6b670d473e66cfd64c11dd5b275e08a353c9fce081cfb69d3125b13886
+EBUILD cloudvpn-1.0.9.ebuild 612 RMD160 f379e704bec2f501a031a09254d21a447d2ed96e SHA1 4d84cce8beb79f45c06536466827b72d675c5f40 SHA256 0f75a244cc388d0f3d4441a9c32721f1d18484f4cc80b4d958b39c0a4ac577fc
+MISC ChangeLog 366 RMD160 40bbe1c2c71ea2c60b3817dacb5bf9c87b0da61b SHA1 d2ddd03ba69005b39f57a53d1c19f7827528a88e SHA256 f7b792a56c9f8745b45423ca0382cb7451234c0cb394b45b0c2a628e2f1ba8a7
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/net-misc/cloudvpn/cloudvpn-1.0.9.ebuild b/net-misc/cloudvpn/cloudvpn-1.0.9.ebuild
new file mode 100644
index 000000000..b5272366f
--- /dev/null
+++ b/net-misc/cloudvpn/cloudvpn-1.0.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="secure mesh networking VPN"
+HOMEPAGE="http://exa.czweb.org/"
+SRC_URI="http://exa.czweb.org/releases/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/openssl"
+DEPEND="dev-util/scons ${RDEPEND}"
+
+src_compile () {
+ # dont pass make's -l option, as scons uses it differently.
+ scons ${MAKEOPTS/-l[0-9]} || die "compilation failed"
+}
+
+src_install () {
+ dobin cloudvpn extras/initscripts/cloudctl || die
+ doman extras/man/cloudvpn.1 || die
+}
+