summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/btg/btg-0.9.0.ebuild')
-rw-r--r--net-p2p/btg/btg-0.9.0.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/net-p2p/btg/btg-0.9.0.ebuild b/net-p2p/btg/btg-0.9.0.ebuild
index 378d4db78..a68af592d 100644
--- a/net-p2p/btg/btg-0.9.0.ebuild
+++ b/net-p2p/btg/btg-0.9.0.ebuild
@@ -6,7 +6,7 @@ inherit eutils
DESCRIPTION="Linux bittorrent client implemented in C++."
HOMEPAGE="http://btg.berlios.de/"
-SRC_URI="mirror://berlios/${PN}/${P}.tar.gz"
+SRC_URI="mirror://berlios/btg/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -23,7 +23,7 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
src_compile() {
- if built_with_use "dev-libs/boost" threads || use built_with_use "dev-libs/boost" threads-only ; then
+ if built_with_use "dev-libs/boost" threads || built_with_use "dev-libs/boost" threads-only ; then
BOOST_LIBS="--with-boost-iostreams=boost_iostreams-mt \
--with-boost-filesystem=boost_filesystem-mt \
--with-boost-thread=boost_thread-mt \
@@ -38,13 +38,13 @@ src_compile() {
$(use_enable gtk gui) \
$(use_enable cppunit) \
$(use_enable session-saving) \
- ${BOOST_LIBS}
+ ${BOOST_LIBS} || die "econf failed"
if use doc ; then
- emake doxygen || die 'generating doc failed'
+ emake doxygen || die "emake doxygen failed"
fi
- emake || die 'compile failed'
+ emake || die "emake failed"
}
src_install() {
@@ -52,4 +52,3 @@ src_install() {
dodoc AUTHORS ChangeLog README TODO
}
-