summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/deluge/deluge-0.4.1-r1.ebuild')
-rw-r--r--net-p2p/deluge/deluge-0.4.1-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-p2p/deluge/deluge-0.4.1-r1.ebuild b/net-p2p/deluge/deluge-0.4.1-r1.ebuild
new file mode 100644
index 000000000..5ac0eb788
--- /dev/null
+++ b/net-p2p/deluge/deluge-0.4.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils python multilib
+
+DESCRIPTION="BitTorrent client in Python and PyGTK."
+HOMEPAGE="http://deluge-torrent.org/"
+SRC_URI="http://deluge-torrent.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome"
+
+DEPEND=">=dev-lang/python-2.3
+ dev-libs/boost
+ >=dev-python/pygtk-2
+ ~dev-python/python-libtorrent-0.4.0
+ dev-python/pyxdg
+ gnome? ( dev-python/notify-python )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ use amd64 && epatch "${FILESDIR}"/${P}-64bit.patch
+}
+
+src_install() {
+ python_version
+ insinto "/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}"
+ doins -r *.py glade/ pixmaps/ plugins/
+
+ newicon pixmaps/${PN}-32.png ${PN}.png
+ make_wrapper ${PN} "/usr/bin/python /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}/${PN}.py"
+ make_desktop_entry ${PN} ${PN}
+
+ dodoc README
+}
+pkg_postinst() {
+ python_version
+ python_mod_optimize "${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/${PN}"
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup "${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/${PN}"
+}