summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/qbittorrent/qbittorrent-0.7.0.ebuild')
-rw-r--r--net-p2p/qbittorrent/qbittorrent-0.7.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/qbittorrent-0.7.0.ebuild b/net-p2p/qbittorrent/qbittorrent-0.7.0.ebuild
new file mode 100644
index 000000000..9102d6baa
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-0.7.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="BitTorrent client in C++ and Qt."
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=net-libs/rb_libtorrent-0.11_rc1
+ =x11-libs/qt-4.1*
+ >dev-lang/python-2.3
+ dev-libs/boost
+ net-misc/curl"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! built_with_use dev-libs/boost threads; then
+ eerror "dev-libs/boost has to be built with threads USE-flag."
+ die "Missing threads USE-flag for dev-libs/boost"
+ fi
+}
+
+src_compile() {
+ ./configure --prefix=/usr || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc AUTHORS Changelog NEWS README TODO
+}