summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/clover/clover-2006.07.17.ebuild')
-rw-r--r--sci-biology/clover/clover-2006.07.17.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-biology/clover/clover-2006.07.17.ebuild b/sci-biology/clover/clover-2006.07.17.ebuild
new file mode 100644
index 000000000..4cf143b0f
--- /dev/null
+++ b/sci-biology/clover/clover-2006.07.17.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit versionator toolchain-funcs
+
+MY_PV=$(replace_all_version_separators '-')
+
+DESCRIPTION="Cis-eLement OVERrepresentation: Detection of functional DNA motifs"
+HOMEPAGE="http://zlab.bu.edu/clover/"
+SRC_URI="http://zlab.bu.edu/~mfrith/downloads/${PN}-${MY_PV}.tar.gz http://zlab.bu.edu/clover/jaspar2005core"
+
+LICENSE="as-is"
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_unpack() {
+ unpack ${PN}-${MY_PV}.tar.gz
+}
+
+src_compile() {
+ sed -i "s:g++:$(tc-getCXX):; s:-Wall -O3:${CFLAGS}:" Makefile || die "sed failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin clover
+ dodir "/usr/share/${PN}"
+ insinto "/usr/share/${PN}"
+ doins ${DISTDIR}/jaspar2005core || die
+}
+
+pkg_postinst() {
+ einfo "The motif library jaspar2005core has been installed in"
+ einfo " /usr/share/clover/jaspar2005core"
+ einfo "You can pass this library to clover for motif search, or use your own library."
+}