summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libquantum/libquantum-1.1.0.ebuild')
-rw-r--r--sci-libs/libquantum/libquantum-1.1.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-libs/libquantum/libquantum-1.1.0.ebuild b/sci-libs/libquantum/libquantum-1.1.0.ebuild
new file mode 100644
index 000000000..cac77ee13
--- /dev/null
+++ b/sci-libs/libquantum/libquantum-1.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+DESCRIPTION="C library for quantum computing and quantum simulation"
+HOMEPAGE="http://www.libquantum.de/"
+SRC_URI="http://www.libquantum.de/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="+lapack examples profile"
+
+DEPEND="lapack? ( virtual/lapack )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_with lapack) \
+ $(use_enable profile profiling)
+}
+
+src_compile() {
+ emake || die
+ emake quobtools || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" quobtools_install || die
+ dodoc CHANGES || die
+ if use examples ; then
+ docinto examples/
+ newdoc INSTALL INSTALL.how_to_compile_own_stuff || die
+ dodoc shor.c grover.c || die
+ fi
+}