summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libtifiles2/libtifiles2-20061030.ebuild')
-rw-r--r--sci-libs/libtifiles2/libtifiles2-20061030.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-libs/libtifiles2/libtifiles2-20061030.ebuild b/sci-libs/libtifiles2/libtifiles2-20061030.ebuild
new file mode 100644
index 000000000..a53fa7c83
--- /dev/null
+++ b/sci-libs/libtifiles2/libtifiles2-20061030.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="library for TI calculator files"
+HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
+SRC_URI="mirror://sourceforge/gtktiemu/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+DEPEND=">=dev-libs/glib-2
+ sci-libs/libticables2
+ sci-libs/libticonv
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/libtifiles
+
+src_compile() {
+ econf $(use_enable nls) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS LOGO NEWS README ChangeLog docs/api.txt
+ dohtml docs/html/*
+}