summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/dataplot/ChangeLog4
-rw-r--r--sci-mathematics/dataplot/Manifest4
-rw-r--r--sci-mathematics/dataplot/dataplot-20080225.ebuild4
3 files changed, 8 insertions, 4 deletions
diff --git a/sci-mathematics/dataplot/ChangeLog b/sci-mathematics/dataplot/ChangeLog
index ad247957b..5d79ae50a 100644
--- a/sci-mathematics/dataplot/ChangeLog
+++ b/sci-mathematics/dataplot/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 19 Apr 2008; Thomas Anderson <gentoofan23@gentoo.org>
+ dataplot-20080225.ebuild:
+ Move -I/usr/include/GL from `use gd` conditional to `use gl`
+
16 Apr 2008; Thomas Anderson (gentoofan23) <gentoofan23@gmail.com>
dataplot-20080225.ebuild:
Various style fixes from bicatali
diff --git a/sci-mathematics/dataplot/Manifest b/sci-mathematics/dataplot/Manifest
index 1061c6622..ca15397f7 100644
--- a/sci-mathematics/dataplot/Manifest
+++ b/sci-mathematics/dataplot/Manifest
@@ -1,6 +1,6 @@
AUX dpsrc-patchset-20080225.patch 2672 RMD160 5877cc97e034c52a4228fe19d87fc2d9a7ae043d SHA1 4377f353fb3de6f598884d542fc0c1842a3c29a9 SHA256 022995d5dca408d099c95165476c47f633a91273b931405cb1a90b27ae1113a1
DIST dplib.02_25_2008.tar.gz 5340447 RMD160 51b5892c83bb5d420f324e3dab5edec24925f728 SHA1 3a77ed5e1e49f377083a11b8a177f678284b91f2 SHA256 7f9a30ae8ab029e0eeca4fbe08e665b572ec98a05ec001a67f95e4857d2a5b05
DIST dpsrc.02_25_2008.tar.gz 6399167 RMD160 ed14f8ceb225e86f25026916ab4934a140f602ae SHA1 f1023d99ec7d2a64611dabedfbc5ad6f16e67cf7 SHA256 794bedcc48cf444c5813f864f4bacb158474d450337279edaf7fba1055c552c6
-EBUILD dataplot-20080225.ebuild 3040 RMD160 837e5a4ade5978a8fd274acb21140ca17d5ec943 SHA1 11cf488e346ee434eb16c345f930a1371f01371a SHA256 9d30ca16bc6e9403d46f393c6b5e86da85f71317043657e5f4c8f29be5a17c1c
-MISC ChangeLog 937 RMD160 cdfd2a3c4e0d9aa65e7aa697f25074a8aae154d0 SHA1 3a49deb9369283db99327586ff9c50d946ad09fa SHA256 eb70d669e6bfaac58d777aa09f9c88a2466c8b48d35beb7846140912e678d013
+EBUILD dataplot-20080225.ebuild 3040 RMD160 153c445e9d7808d6ce0b82eab77c1d2fad92c69c SHA1 896d70deaf2fb5c1525c1da84782212302c36c35 SHA256 4d2066d12a2eee922338ac3cd8ea6bc5afc03ba262867047de01dd3a49e0ae4e
+MISC ChangeLog 1085 RMD160 4955181356e93d6431ce0d4f5302b89f42ca1433 SHA1 a81eb3703ea0a16772a376838b5d6da8ec609a4f SHA256 771cb585cf9d58c6973048d460020968c519a7358ebf774a92c6268f17e0ad2e
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/sci-mathematics/dataplot/dataplot-20080225.ebuild b/sci-mathematics/dataplot/dataplot-20080225.ebuild
index 119f4afa8..55a803253 100644
--- a/sci-mathematics/dataplot/dataplot-20080225.ebuild
+++ b/sci-mathematics/dataplot/dataplot-20080225.ebuild
@@ -81,14 +81,14 @@ src_compile() {
##Compile x11/gd/opengl device drivers
if use gd; then
- $(tc-getCC) -c ${CFLAGS} -I/usr/include/GL gd_src.c || die "Compiling gd_src.c
+ $(tc-getCC) -c ${CFLAGS} gd_src.c || die "Compiling gd_src.c
failed!"
else
${FORTRANC} ${FFLAGS} gd_src.f || die "Compiling gd_src.f failed!"
fi
if use opengl; then
- $(tc-getCC) -c ${CFLAGS} -DUNIX_OS -DAPPEND_UNDERSCORE \
+ $(tc-getCC) -c ${CFLAGS} -I/usr/include/GL -DUNIX_OS -DAPPEND_UNDERSCORE \
-DSUBROUTINE_CASE gl_src.c || die "Compiling gl_src.c
failed!"
else