summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/zhu3d/zhu3d-2.9.8.ebuild')
-rw-r--r--sci-visualization/zhu3d/zhu3d-2.9.8.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-visualization/zhu3d/zhu3d-2.9.8.ebuild b/sci-visualization/zhu3d/zhu3d-2.9.8.ebuild
new file mode 100644
index 000000000..af96d0699
--- /dev/null
+++ b/sci-visualization/zhu3d/zhu3d-2.9.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils toolchain-funcs qt4
+
+KEYWORDS="~x86"
+
+DESCRIPTION="View and animate up to three functions in 3D-space in a completely interactive manner."
+HOMEPAGE="http://www.kde-apps.org/content/show.php?content=43071"
+SRC_URI="http://www.kde-apps.org/CONTENT/content-files/43071-zhu3d-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="$(qt4_min_version 4.0)
+ virtual/glu"
+RDEPEND="${DEPEND}"
+QT4_BUILT_WITH_USE_CHECK="opengl"
+
+src_compile() {
+ eqmake4 ${PN}.pro SYSDIR="/usr/share/${PN}/system" DOCDIR="/usr/share/doc/${P}/html"
+ emake CXX=$(tc-getCXX) || die "emake failed"
+}
+
+src_install() {
+ dobin zhu3d
+
+ dodoc readme.txt
+ dohtml doc/*
+
+ insinto /usr/share/${PN}
+ doins -r work system
+
+ doicon system/icons/${PN}.png
+ make_desktop_entry ${PN} "Zhu3D: Interactive 3D function viewer" ${PN}.png "Education;Science;Math;Qt"
+}