summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/openguru/openguru-1.ebuild')
-rw-r--r--sys-apps/openguru/openguru-1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/openguru/openguru-1.ebuild b/sys-apps/openguru/openguru-1.ebuild
new file mode 100644
index 000000000..b969264ed
--- /dev/null
+++ b/sys-apps/openguru/openguru-1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="openGuru is a utility used to read Abit uGuru sensors"
+HOMEPAGE=""
+SRC_URI="http://hem.bredband.net/b330708/oguru/oguru.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+S=${WORKDIR}
+
+
+src_compile() {
+ ! has_hardened && CFLAGS="${CFLAGS} -Wl,-z,now"
+ $(tc-getCC) ${CFLAGS} -o ${PN} main.c openGuru.c || die "Compile failed"
+}
+
+src_install() {
+ into /usr
+ dobin openguru
+ # segfaults if not run with root privs
+ fowners root:wheel /usr/bin/openguru
+ fperms 4510 /usr/bin/openguru
+}
+
+pkg_postinst() {
+ einfo "Now you can run ${PN} as root to read sensors values."
+ ewarn "If you want non-root users to be able to use ${PN} as well,"
+ ewarn "you must add them to wheel group - see man usermod."
+}