summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/fuse-zip/fuse-zip-0.2.8.ebuild')
-rw-r--r--sys-fs/fuse-zip/fuse-zip-0.2.8.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-fs/fuse-zip/fuse-zip-0.2.8.ebuild b/sys-fs/fuse-zip/fuse-zip-0.2.8.ebuild
new file mode 100644
index 000000000..6fd8c2082
--- /dev/null
+++ b/sys-fs/fuse-zip/fuse-zip-0.2.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="FUSE file system to navigate, extract, create and modify ZIP archives based on libzip"
+HOMEPAGE="http://code.google.com/p/fuse-zip/"
+SRC_URI="http://fuse-zip.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-libs/libzip
+ sys-fs/fuse"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Fix strip than installing fuse-zip
+ sed -i -e 's/install -m 755 -s/install -m 755/' Makefile || die "sed failed"
+}
+
+src_install() {
+ emake INSTALLPREFIX="${D}"/usr install || die "Failed to install"
+ prepalldocs
+}