summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fusepod/ChangeLog8
-rw-r--r--sys-fs/fusepod/Manifest6
-rw-r--r--sys-fs/fusepod/files/fusepod-0.5.2-64bit-fixes.patch29
-rw-r--r--sys-fs/fusepod/files/fusepod-0.5.2-additional-headers.patch20
-rw-r--r--sys-fs/fusepod/fusepod-0.5.2-r1.ebuild (renamed from sys-fs/fusepod/fusepod-0.5.2.ebuild)9
5 files changed, 69 insertions, 3 deletions
diff --git a/sys-fs/fusepod/ChangeLog b/sys-fs/fusepod/ChangeLog
index dda6518ef..86d59ce56 100644
--- a/sys-fs/fusepod/ChangeLog
+++ b/sys-fs/fusepod/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for sys-fs/fusepod
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 23 Aug 2010; Maks Verver (Soultaker) <maksverver@geocities.com>
+ -fusepod-0.5.2.ebuild, +fusepod-0.5.2-r1.ebuild,
+ +files/fusepod-0.5.2-64bit-fixes.patch,
+ +files/fusepod-0.5.2-additional-headers.patch:
+ Fixed building with recent headers. Fixed broken 64-bit support.
+
08 Apr 2008; Charles Clément <caratorn@gmail.com>
-files/fusepod-0.5.1-libgpod-api-fix.patch:
Remove old patch
diff --git a/sys-fs/fusepod/Manifest b/sys-fs/fusepod/Manifest
index 725af6cb3..980f59e96 100644
--- a/sys-fs/fusepod/Manifest
+++ b/sys-fs/fusepod/Manifest
@@ -1,4 +1,6 @@
+AUX fusepod-0.5.2-64bit-fixes.patch 1012 RMD160 7b6c67609ddf7f6ee52c80a2acb1d7d6d7c08d92 SHA1 c6abc8d607649b4a597b81b20c8bac9a894baa13 SHA256 26076a9cb0bd24d0e19abed42da774f0e924452467c1efec4e2a1354d3877fe1
+AUX fusepod-0.5.2-additional-headers.patch 514 RMD160 230bb2f87580188fe34107514a1aca0e40dc78ae SHA1 75e8cffffe82701a4730c2eb5dac28c7d4c7bd4d SHA256 477a9becb23b19e15184a951150086ed990c0068f8c8679fd8075876f6b34e27
DIST fusepod-0.5.2.tar.bz2 80923 RMD160 34b47ba7247afb4bf809d6088c6f8e32ca1b1eab SHA1 706f0541e80a3e72e74db384503198e07a2b4b35 SHA256 210d77cb2ec7701d4af681e63c4f52bc4d0c8cbfa493f55d3d9580e7106b857f
-EBUILD fusepod-0.5.2.ebuild 574 RMD160 620b2d3b2491e87cc8af53e391484a9cf8481519 SHA1 d0583bf116e2fc23256ded0a30c6efad36eaf1a1 SHA256 706281c80b84f841dcb406a4d644b3c6692f4c34ff76fb11a09302e494f99c02
-MISC ChangeLog 661 RMD160 63b98ace5501d905cc331c7eda76d31a17a368e1 SHA1 ad0a6ea3268ebace1fdefabf9d70861d30ee6636 SHA256 5b7e807d259ac714faf10634677f1ec78de2a0fa7f43f68d229c1919936e4dba
+EBUILD fusepod-0.5.2-r1.ebuild 716 RMD160 453281f5b6fcf71baf6a64a329a768df5bdbaa84 SHA1 b990f6593d80d49bd65ebedd04e0886c0a53490d SHA256 be5401e857976e3c428ef70e207a1d0b35e4bc79bbae1991256d1b0623f8d76d
+MISC ChangeLog 937 RMD160 a8e6d725dea5823ee06ec4f35ad88b73ccee452d SHA1 4f050c681d9a9657770b22d0353e5aea16366d58 SHA256 b3a77257b509efd4f1e8f7c3e0bb5c09ebaf4c35a35e9bcd7524ab8ab2bb86de
MISC metadata.xml 229 RMD160 f0f6417bec31ce8baba6d476664f7210c8c84c98 SHA1 e5f94f5caadc6f843fc90bb7959570cd503676fd SHA256 3b08fca3c878bdfc4e7639f477dd542d55a4ab5dce39a475e82633071d13eb3f
diff --git a/sys-fs/fusepod/files/fusepod-0.5.2-64bit-fixes.patch b/sys-fs/fusepod/files/fusepod-0.5.2-64bit-fixes.patch
new file mode 100644
index 000000000..fdd4a834a
--- /dev/null
+++ b/sys-fs/fusepod/files/fusepod-0.5.2-64bit-fixes.patch
@@ -0,0 +1,29 @@
+--- src.bak/fusepod_ipod.cpp 2010-08-21 00:02:22.000000000 +0200
++++ src/fusepod_ipod.cpp 2010-08-21 00:25:38.000000000 +0200
+@@ -231,7 +231,7 @@
+ {"m4a", "mp4"},
+ {"m4p", "mp4"} };
+
+- unsigned int pos = path.rfind ('.');
++ size_t pos = path.rfind ('.');
+ if (pos == string::npos) {
+ itdb_track_free (track);
+ return 0;
+--- src.bak/fusepod_util.cpp 2010-08-21 00:23:41.000000000 +0200
++++ src/fusepod_util.cpp 2010-08-21 00:34:30.000000000 +0200
+@@ -27,11 +27,11 @@
+ }
+
+ string fusepod_strip_string (const string & s) {
+- unsigned int l = s.find_first_not_of (" \t\n\r");
++ size_t l = s.find_first_not_of (" \t\n\r");
+ if (l == string::npos)
+ return "";
+- int r = s.find_first_not_of (" \t\n\r");
+- return s.substr (l, s.length () - r);
++ size_t r = s.find_last_not_of (" \t\n\r");
++ return s.substr (l, r + 1 - l);
+ }
+
+ string fusepod_check_string (const string & s, const string & unknown) {
+
diff --git a/sys-fs/fusepod/files/fusepod-0.5.2-additional-headers.patch b/sys-fs/fusepod/files/fusepod-0.5.2-additional-headers.patch
new file mode 100644
index 000000000..2046ec42c
--- /dev/null
+++ b/sys-fs/fusepod/files/fusepod-0.5.2-additional-headers.patch
@@ -0,0 +1,20 @@
+--- src.bak/fusepod_util.cpp 2010-08-21 00:02:22.000000000 +0200
++++ src/fusepod_util.cpp 2010-08-21 00:03:23.000000000 +0200
+@@ -14,6 +14,7 @@
+
+ #include "fusepod_util.h"
+
++#include <cstdio> // for sprintf()
+ #include <cstring>
+ #include <set>
+
+--- src.bak/fusepod_util.h 2010-08-21 00:02:22.000000000 +0200
++++ src/fusepod_util.h 2010-08-21 00:02:50.000000000 +0200
+@@ -17,6 +17,7 @@
+
+ #include <vector>
+ #include <string>
++#include <strings.h> // for strcasecmp
+
+ using std::string;
+ using std::vector;
diff --git a/sys-fs/fusepod/fusepod-0.5.2.ebuild b/sys-fs/fusepod/fusepod-0.5.2-r1.ebuild
index 861ac22e0..e7618e36a 100644
--- a/sys-fs/fusepod/fusepod-0.5.2.ebuild
+++ b/sys-fs/fusepod/fusepod-0.5.2-r1.ebuild
@@ -2,6 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="2"
+
+inherit eutils
+
DESCRIPTION="A userspace filesystem to mount your iPod into a
directory for easy browsing"
HOMEPAGE="http://sourceforge.net/projects/fusepod"
@@ -17,6 +21,11 @@ DEPEND="sys-fs/fuse
media-libs/taglib"
RDEPEND="${DEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}/${P}-additional-headers.patch"
+ epatch "${FILESDIR}/${P}-64bit-fixes.patch"
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog README THANKS TODO