summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/powerthend/powerthend-1.1.1.ebuild')
-rw-r--r--sys-power/powerthend/powerthend-1.1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-power/powerthend/powerthend-1.1.1.ebuild b/sys-power/powerthend/powerthend-1.1.1.ebuild
new file mode 100644
index 000000000..9e85ebaf9
--- /dev/null
+++ b/sys-power/powerthend/powerthend-1.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Daemon to control the speed and voltage of CPUs"
+HOMEPAGE="http://powerthend.scheissname.de/"
+SRC_URI="http://powerthend.scheissname.de/sources/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i "s:-O2:${CFLAGS}:" Makefile
+}
+
+src_compile() {
+ emake powerthend || die "make failed"
+}
+
+src_install() {
+ dosbin powerthend || die
+ dodoc README
+
+ doconfd ${FILESDIR}/powerthend.confd powerthend
+ doinitd ${FILESDIR}/powerthend.rc powerthend
+}