summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/powerthend')
-rw-r--r--sys-power/powerthend/ChangeLog5
-rw-r--r--sys-power/powerthend/Manifest4
-rw-r--r--sys-power/powerthend/powerthend-1.1.1.ebuild10
3 files changed, 11 insertions, 8 deletions
diff --git a/sys-power/powerthend/ChangeLog b/sys-power/powerthend/ChangeLog
index 722d54174..b6a6753cf 100644
--- a/sys-power/powerthend/ChangeLog
+++ b/sys-power/powerthend/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for sys-power/powerthend
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 29 Jan 2010; Piotr Szymaniak <lazy_bum@o2.pl> powerthend-1.1.1.ebuild:
+ Added die to dodoc, added src_prepare and EAPI declaration.
+
19 Jul 2008; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
powerthend-1.1.1.ebuild:
Add an existing source location
diff --git a/sys-power/powerthend/Manifest b/sys-power/powerthend/Manifest
index d448b00b2..d629638d3 100644
--- a/sys-power/powerthend/Manifest
+++ b/sys-power/powerthend/Manifest
@@ -1,6 +1,6 @@
AUX powerthend.confd 163 RMD160 c60c3c7af96007abd0c1ed1721eec60756d38b6e SHA1 20b3f3d9972fa58d79cddb4289667b73014160b0 SHA256 24ef9d4fae66e80f4c3a4891512c064574fe9147972abd5aa1caaadfa80d425f
AUX powerthend.rc 369 RMD160 2f991a2490f656cd5c4e02edf8a1e1cfa9a03903 SHA1 2486c6637bc8c3f258a581eea195cb2189013c62 SHA256 59929057f8a14065ff193885fd05161a67390198a9224b60640633fa8914c851
DIST powerthend-1.1.1.tar.gz 15825 RMD160 517f45b63cc42715a0b3117d9b0b12675ded5e46 SHA1 a6de3bd7f9f630bfa52ae8b7d50d7fd838345ff2 SHA256 f8c90436891a17db5821bee0aa6c185c3ecc331aee5767224fd6203334c1422f
-EBUILD powerthend-1.1.1.ebuild 677 RMD160 9ac6a833057e3baeeae6cd755ceb11c14e86b35a SHA1 1ccbf18255999bae5087d98282d2ee22b024adcd SHA256 abf263a186a5b22c534e6ab375ac07f22f530b542fefccaf79e9cb38e8407d23
-MISC ChangeLog 654 RMD160 b748bc66721398604499501b75276cd6377c9561 SHA1 2b5b62fb6d7e79f1a12410d31a1033ac97b899c7 SHA256 d142003b29b517942eb114d0b3566aa48132c07cbbc6d9ae818cf33a1d072833
+EBUILD powerthend-1.1.1.ebuild 684 RMD160 4be264743281acff67250729daaa1fb453a367dc SHA1 055e77d5db4eaf8e2847f92ff1367216961bd587 SHA256 d7e2a1a45115766e3af56c9a7f680ac97a602e05e8e566840569a9f083b5be92
+MISC ChangeLog 790 RMD160 9f01755f1e6d0e84354d6cfb26f697be0813c245 SHA1 82f0ed36133179efa4a3fbb670af75917fff7ba9 SHA256 e06ce25a38780e0783620b7d37c2526f64e638200ad31ef446f379421903efc2
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/sys-power/powerthend/powerthend-1.1.1.ebuild b/sys-power/powerthend/powerthend-1.1.1.ebuild
index 55b7284bf..96c8f857a 100644
--- a/sys-power/powerthend/powerthend-1.1.1.ebuild
+++ b/sys-power/powerthend/powerthend-1.1.1.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI=2
+
DESCRIPTION="Daemon to control the speed and voltage of CPUs"
HOMEPAGE="http://powerthend.scheissname.de/"
SRC_URI="http://dev.gentooexperimental.org/~tommy/distfiles/${P}.tar.gz"
@@ -11,9 +13,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
sed -i "s:-O2:${CFLAGS}:" Makefile
}
@@ -23,7 +23,7 @@ src_compile() {
src_install() {
dosbin powerthend || die "dosbin failed"
- dodoc README
+ dodoc README || die "dodoc failed"
newconfd "${FILESDIR}/powerthend.confd" powerthend
newinitd "${FILESDIR}/powerthend.rc" powerthend